Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: Estey Organ Co doesn’t seem to work when pumping.

  1. #21
    ff Fortissimo SubBase's Avatar
    Join Date
    Sep 2007
    Location
    WV
    Posts
    1,077

    I meant the picture on the treble side, that is where the forte stop is lifting the rear swell.

  2. #22
    ppp Pianississmo Christojo's Avatar
    Join Date
    Mar 2018
    Posts
    12

    Quote Originally Posted by SubBase View Post
    I meant the picture on the treble side, that is where the forte stop is lifting the rear swell.
    Yes Casey, I just checked and when pushed the rear is lifted.
    Thanks

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Prozor midi to usb doesn’t work with Orla Grande organ
    By toneharb12 in forum MIDI Devices & Software
    Replies: 6
    Last Post: 02-06-2018, 08:57 PM
  2. One of my Hammond M3 Pedals doesn't work - need help
    By Allan Flatoff in forum Hammond Organs
    Replies: 0
    Last Post: 10-07-2017, 11:59 AM
  3. Reverb doesn't work on my Hammond B3000
    By hammondpow7 in forum Electronic Organs
    Replies: 28
    Last Post: 08-31-2016, 04:52 PM
  4. M102 foot pedals work but keyboard doesn't.
    By Callumduffy in forum Hammond Organs
    Replies: 0
    Last Post: 09-13-2013, 06:26 PM
  5. Expression Pedal Doesn't work
    By batinich in forum Home Organs
    Replies: 7
    Last Post: 11-24-2008, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •